8 thoughts on “Help needed

  1. Hi Robin,
    I’m in the US – Tennessee – fiber optic cable. Your site loads slower than other sites, and slower than it used to load. We’re looking at a 10 to 15 second load time vs. other sites like ZH which seem to load instantly. It’s not a deal breaker for me, I’m willing to wait, still hoping it can be fixed without too much stress on your end.

  2. Hi Robin,
    I’m in the US, Florida, with a 25meg line speed. A week or two ago there was a marked change in your site loading. I keep expecting to get a “your request timed out”, but thankfully that hasn’t happened yet. But you are getting throttled by someone/something.
    New site looks great, btw!

    1. Robin,
      The loading times for your site have improved since my previous post. 4-5 seconds today. Not the fastest, but certainly not problematic any more.

  3. Hi, I have Fiber Optic 100Mb/s Down / 30Mb/s Up.

    I have noticed in the past month or so, your site has been loading slower on occasion… About 5-10 seconds wait time, for the homepage, or clicking an article. When it is slower, other days it’s fine.

    I live in Eastern Canada, so I am first in line, at the undersea cable that connects Iceland/Greenland.
    For whatever that is worth.

  4. Where as I’ll raise my hand as an apparent anomaly and say my daily check in to the site over the past 6 months had been consistently zippy with no apparent slow downs.

Leave a Reply

Your email address will not be published. Required fields are marked *

Wordpress Social Share Plugin powered by Ultimatelysocial
RSS